Welcome to the New Restek.com! Take a tour of the new site and feel free to send us your feedback.

Your web browser will no longer be supported by Restek.com as of 30 June 2021.
To avoid any interruption in access or functionality, install a current-generation web browser now. Learn more.

Previous-Generation Web Browsers Will No Longer Be Supported by Restek.com as of 30 June 2021 — Upgrade Today

  • Share:

We understand there are several reasons why you may prefer to use your old web browser for online activity; however, Restek.com can no longer support previous-generation web browsers after 30 June 2021. We strongly encourage updating your browser now.

Why Are Previous-Generation Browsers No Longer Supported by Restek.com? 

The primary reason is your security. Once a browser is no longer being updated, the latest online security measures are not available, which makes your personal information and your computer vulnerable to attack when you go online. Switching to Microsoft Edge, Google Chrome, Apple Safari, or another current-generation browser, and keeping up with routine software updates, is always recommended to protect yourself and your privacy online. 

Another reason to switch your web browser is to ensure that you have the best possible online experience. Our website has many features that outdated browsers simply cannot deliver sufficiently. By updating your browser, you will help make sure that you get the most out of every visit to Restek.com 

How Can I Change My Web Browser? 

Installing a current-generation web browser is easy. Simply navigate to the web page for your preferred browser and follow the instructions to download. We do not recommend a specific browser, but here are links to several popular current-generation browsers that have been thoroughly tested for compatibility with Restek.com: 

Microsoft Edge (Windows): www.microsoft.com/edge  

Google Chrome (Windows or Mac): www.google.com/chrome 

Apple Safari (Mac): https://support.apple.com/safari   

(Contact your IT department if you need assistance with updating your browser.)

GNOT3516-UNV